Full Version: PlotLab Admin rights required?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

I am currently trying to upgrade from Delphi XE7 to 10.1 Berlin Professional on a Windows 7 machine. I also downloaded and installed PlotLab But when I run 10.1 as a standard user, the PlotLab components are missing. When I run 10.1 as administrator, all the PlotLab components are there.

In the past, I used to run Delphi as standard user and everything worked fine. What can I do to see PlotLab as standard user in 10.1 Berlin ? Is there anything I am doing wrong ?

Best regards,
Thank you!
Not sure why the components would be missing :-( . You will probably need admin rights to compile unless you set the read/write permissions for the OpenWire and LabPacks directories. So far I have never seen the components disappear if Delphi is not ran as admin.
With best regards,
Thank you for your reply, Boian!
Maybe I had a problem with the different user names for the standard user (User_1) and the admin (User_2) when running setup.exe.
Instead of entering the admin password when prompted, I meanwhile tried the following and it worked successfully:
- Changed User_1 account from standard user to admin.
- Ran all the setup routines as User_1 (Delphi 10.1 + PlotLab + other components).
- Changed User_1 account back to standard user.
I can now run the IDE as User_1 and all the components are there.
Best regards,
Reference URL's